16 junio, 2021

OBTENER VALOR DE LA ÚLTIMA CELDA DE UNA FILA

Hola a todos:

Hace unos días me comentaron que tenía que publicar un poco más sobre formulación en Excel. La verdad es que tienen razón, dado que esta web trata sobre Excel así que hoy trataré sobre fórmulas y sobre una consulta que me llegó hace un par de días.

La consulta estaba relacionada con este post: OBTENER VALOR DE LA ÚLTIMA CELDA DE UNA COLUMNA y me pedían modificar las fórmulas de esa post para que funcionasen en filas. Por lo que, al igual que en el post anterior, voy a indicar aquí cada fórmula:

  • =DESREF(A5;0;CONTAR(5:5)) Cuando el rango de datos no contiene celdas vacías y la información es numérica. En caso de que la información no sea numérica, podremos cambiar la función CONTAR por CONTARA  y a continuación - 1 y funcionará correctamente así: =DESREF(A5;0;CONTARA(5:5)-1).
  • =BUSCAR(MAX(5:5)+1;(5:5)) Cuando el rango de datos contenga celdas vacías o el rango sea continuo y la información sea numérica.
  • =INDICE(5:5;MAX(COLUMNA(5:5)*(5:5<>""))) Fórmula matricial, válida para todos los casos, datos numéricos, texto, con celdas vacías en el rango o información continua.

Como podéis observar, simplemente hay que adaptar los rangos y el funcionamiento será idéntico.

Si necesitáis delimitar los rangos y no utilizar filas completas, por ejemplo de B5:H5, lo tendríais que hacer así:

  • =DESREF(A5;0;CONTAR(B5:H5))
  • =DESREF(A5;0;CONTARA(B5:H5))
  • =BUSCAR(MAX(B5:H5)+1;(B5:H5))
  • =INDICE(A5:H5;MAX(COLUMNA(B5:H5)*(B5:H5<>"")))

En el caso de la segunda fórmula, y dado que ya no incluimos el literal, no es necesario incluir el -1.

Y esto es todo!, espero que os hayan gustado las fórmulas 🙂

Descarga el archivo de ejemplo pulsando en:

¿Te ha resultado de interés?, puedes apoyar a Excel Signum con una pequeña donación.

Donate Button with Credit Cards

¡¡Muchas gracias!!

Mediante la suscripción al blog, la realización comentarios o el uso del formulario de contacto estás dando tu consentimiento expreso al tratamiento de los datos personales proporcionados según lo dispuesto en la ley vigente (LOPD). Tienes más información al respecto en esta página del blog: Política de Privacidad y Cookies

Comparte este post

6 comentario en “OBTENER VALOR DE LA ÚLTIMA CELDA DE UNA FILA

  1. MUY BIEN, GRACIAS POR TU APORTACIÓN.
    PODRÉ OBTENER VALOR DE LA ÚLTIMA CELDA DE UNA FILA PERO CON DATOS QUE INCLUYA FECHAS, CREO QUE NO FUNCIONÓ.

    SALUDOS.

    JORGE AHUMADA

  2. Utilizando la matricial, y utilizando un rango, me aparece el error "Función Índice parámetro 3 valor 127 esta fuera de rango". Eso por qué sería?

Si te ha gustado o tienes alguna duda, puedes dejar aquí tu comentario.

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies