7 mayo, 2021

CALCULAR PROMEDIO SIN TENER EN CUENTA LOS CEROS

Hola a todos,

Espero que hay√°is disfrutado del verano y de las vacaciones ūüôā seguro que s√≠!!. Bien, hoy voy a realizar una entrada muy corta pero que se presenta muy habitualmente en nuestras hojas de c√°lculo: el c√°lculo de los promedios sin tener en cuenta los ceros.

La funci√≥n "Promedio" en Excel calcula el promedio en un rango definido de datos, es una f√≥rmula sencilla y muy √ļtil. No tiene en cuenta las celdas que no contienen datos (vac√≠as) pero s√≠ que tiene en cuenta las celdas que contienen un "0".

Normalmente esto no representa un problema, el cero se asume con un n√ļmero m√°s y se realiza el promedio. Pero ¬Ņqu√© sucede si no debemos tener en cuenta los ceros en nuestros c√°lculos?, por ejemplo, en los resultados de facturaci√≥n de un grupo de vendedores en el primer semestre del a√Īo, imaginad que se han ido de vacaciones (y que todos han tomado el mes que le corresponde). Veamos el c√°lculo del promedio con la f√≥rmula habitual:

calcular-promedio-sin-tener-en-cuenta-ceros1

Así es, el promedio por línea se calcula así:

=PROMEDIO(C3:I3)

Como podéis observar en el primer caso, el comercial Arturo ha facturado un promedio de 1.352,14 euros en el primer semestre. Pero dado que en Julio se fue de vacaciones y en nuestra empresa tenemos este dato muy en cuenta, el promedio lo queremos obtener de aquellos meses en los que ha trabajado. En realidad Arturo ha obtenido un promedio de 1.557,50 euros (fruto de los meses de Enero a Junio).

Esto lo vamos a calcular con una fórmula matricial que va a omitir del cálculo del promedio aquellas celdas que contengan un "0", ya sabéis que para introducir una fórmula matricial es necesario que seleccionéis la fórmula y luego pulséis: Ctrol + Alt + Enter.

{=PROMEDIO(SI(C17:I17<>0;C17:I17))}

En el cuadro de abajo tenemos los c√°lculos correctamente realizados:

calcular-promedio-sin-tener-en-cuenta-ceros2

Como se puede ver, la diferencia es importante y es algo que se debería tener en cuenta a la hora de realizar promedios.

Descarga el archivo de ejemplo pulsando en: CALCULAR PROMEDIO SIN TENER EN CUENTA LOS CEROS

Comparte este post

5 comentario en “CALCULAR PROMEDIO SIN TENER EN CUENTA LOS CEROS

  1. no me funciona por que las celdas que estoy promediando no están seguidas. ósea se encuentran en diferentes columnas.

    1. Hola Carlos: La función sirve para columnas como para filas y aunque no estén seguidas, no sé que tipo de datos tienes. ten en cuenta que de la celda debe ser distinta de 0 para el promedio, si tiene un espacio en blanco debes cambiar la fórmula.

      Saludos.

  2. existe aguna formula que sea m√°s ex√°cta o m√°s representativa para calcular un promedio, para aplicar en casos donde tenga peak que se escapen demaciado del promedio

Si te ha gustado o tienes alguna duda, puedes dejar aquí tu comentario.

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si contin√ļa navegando est√° dando su consentimiento para la aceptaci√≥n de las mencionadas cookies y la aceptaci√≥n de nuestra pol√≠tica de cookies, pinche el enlace para mayor informaci√≥n.plugin cookies

ACEPTAR
Aviso de cookies