22 abril, 2021

CALCULAR PROMEDIO SIN TENER EN CUENTA LOS CEROS

Hola a todos,

Espero que hayáis disfrutado del verano y de las vacaciones 🙂 seguro que sí!!. Bien, hoy voy a realizar una entrada muy corta pero que se presenta muy habitualmente en nuestras hojas de cálculo: el cálculo de los promedios sin tener en cuenta los ceros.

La función "Promedio" en Excel calcula el promedio en un rango definido de datos, es una fórmula sencilla y muy útil. No tiene en cuenta las celdas que no contienen datos (vacías) pero sí que tiene en cuenta las celdas que contienen un "0".

Normalmente esto no representa un problema, el cero se asume con un número más y se realiza el promedio. Pero ¿qué sucede si no debemos tener en cuenta los ceros en nuestros cálculos?, por ejemplo, en los resultados de facturación de un grupo de vendedores en el primer semestre del año, imaginad que se han ido de vacaciones (y que todos han tomado el mes que le corresponde). Veamos el cálculo del promedio con la fórmula habitual:

calcular-promedio-sin-tener-en-cuenta-ceros1

Así es, el promedio por línea se calcula así:

=PROMEDIO(C3:I3)

Como podéis observar en el primer caso, el comercial Arturo ha facturado un promedio de 1.352,14 euros en el primer semestre. Pero dado que en Julio se fue de vacaciones y en nuestra empresa tenemos este dato muy en cuenta, el promedio lo queremos obtener de aquellos meses en los que ha trabajado. En realidad Arturo ha obtenido un promedio de 1.557,50 euros (fruto de los meses de Enero a Junio).

Esto lo vamos a calcular con una fórmula matricial que va a omitir del cálculo del promedio aquellas celdas que contengan un "0", ya sabéis que para introducir una fórmula matricial es necesario que seleccionéis la fórmula y luego pulséis: Ctrol + Alt + Enter.

{=PROMEDIO(SI(C17:I17<>0;C17:I17))}

En el cuadro de abajo tenemos los cálculos correctamente realizados:

calcular-promedio-sin-tener-en-cuenta-ceros2

Como se puede ver, la diferencia es importante y es algo que se debería tener en cuenta a la hora de realizar promedios.

Descarga el archivo de ejemplo pulsando en: CALCULAR PROMEDIO SIN TENER EN CUENTA LOS CEROS

Comparte este post

5 comentario en “CALCULAR PROMEDIO SIN TENER EN CUENTA LOS CEROS

    1. Hola Carlos: La función sirve para columnas como para filas y aunque no estén seguidas, no sé que tipo de datos tienes. ten en cuenta que de la celda debe ser distinta de 0 para el promedio, si tiene un espacio en blanco debes cambiar la fórmula.

      Saludos.

  1. existe aguna formula que sea más exácta o más representativa para calcular un promedio, para aplicar en casos donde tenga peak que se escapen demaciado del promedio

Si te ha gustado o tienes alguna duda, puedes dejar aquí tu comentario.

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies