AÑADIR CEROS A LA IZQUIERDA EN EXCEL

Muchas veces cuando recibimos una base de datos nos encontramos con que el formato de entrada no es el adecuado y tenemos que proceder a modificarlo según nuestras necesidades. Un ejemplo de este tipo de modificaciones es el de los ceros a la izquierda, en multitud de programas de gestión se usan los ceros a la izquierda para completar campos.

Hay varias fórmulas para realizar este trabajo, aquí os voy a dejar un par de alternativas:
El ejemplo del DNI, pongamos que nos envían un listado de varios miles de posiciones con nombres y DNI y que tiene 9 posiciones, que es lo habitual. Pero en nuestra base de datos es necesario que el campo tenga 11 posiciones que se deben rellenar con ceros a la izquierda, pues bien, la fórmula a utilizar es la siguiente:

=CONCATENAR(REPETIR("0";11-LARGO(A2));A2)

Donde indicaremos entre comillas que lo que queremos poner a la izquierda son ceros y que las posiciones a rellenar son 11. Tomando como ejemplo DNI: 99999999N debemos conseguir: 0099999999N.

Os debería quedar así:

CEROS A LA IZQUIERDA

De esta forma podemos modificar cualquier lista de DNI o cadena de números o texto que necesitemos y con el número y posiciones que deseemos.

Otra forma para hacerlo, pero que nos limitará solo a cadena de números, (no funciona con letras), es la siguiente:

=TEXTO(D2;"0000000000")

Si tenemos el siguiente dato: 11111 y el campo requiere diez posiciones, debería quedar así: 0000011111

CEROS A LA IZQUIERDA_1

El problema es que esta fórmula solo valdrá para cuando trabajemos con números, no podemos usarla con letras o con números y letras, para ese caso recomiendo la primera opción.

Os dejo como siempre el archivo de ejemplo, espero os haya sido de utilidad.

Saludos!!

Descarga el archivo pulsando enCEROS A LA IZQUIERDA EN EXCEL

 

Anuncios

4 pensamientos en “AÑADIR CEROS A LA IZQUIERDA EN EXCEL

  1. Pingback: AÑADIR CEROS A LA IZQUIERDA EN VBA | Excel Signum

¿Te ha gustado?. Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s