23 abril, 2021

AÑADIR CEROS A LA IZQUIERDA EN EXCEL

Muchas veces cuando recibimos una base de datos nos encontramos con que el formato de entrada no es el adecuado y tenemos que proceder a modificarlo según nuestras necesidades. Un ejemplo de este tipo de modificaciones es el de los ceros a la izquierda, en multitud de programas de gestión se usan los ceros a la izquierda para completar campos.

Hay varias fórmulas para realizar este trabajo, aquí os voy a dejar un par de alternativas:
El ejemplo del DNI, pongamos que nos envían un listado de varios miles de posiciones con nombres y DNI y que tiene 9 posiciones, que es lo habitual. Pero en nuestra base de datos es necesario que el campo tenga 11 posiciones que se deben rellenar con ceros a la izquierda, pues bien, la fórmula a utilizar es la siguiente:

=CONCATENAR(REPETIR("0";11-LARGO(A2));A2)

Donde indicaremos entre comillas que lo que queremos poner a la izquierda son ceros y que las posiciones a rellenar son 11. Tomando como ejemplo DNI: 99999999N debemos conseguir: 0099999999N.

Os debería quedar así:

CEROS A LA IZQUIERDA

De esta forma podemos modificar cualquier lista de DNI o cadena de números o texto que necesitemos y con el número y posiciones que deseemos.

Otra forma para hacerlo, pero que nos limitará solo a cadena de números, (no funciona con letras), es la siguiente:

=TEXTO(D2;"0000000000")

Si tenemos el siguiente dato: 11111 y el campo requiere diez posiciones, debería quedar así: 0000011111

CEROS A LA IZQUIERDA_1

El problema es que esta fórmula solo valdrá para cuando trabajemos con números, no podemos usarla con letras o con números y letras, para ese caso recomiendo la primera opción.

Os dejo como siempre el archivo de ejemplo, espero os haya sido de utilidad.

Saludos!!

Descarga el archivo pulsando enCEROS A LA IZQUIERDA EN EXCEL

 

Comparte este post

8 comentario en “AÑADIR CEROS A LA IZQUIERDA EN EXCEL

Si te ha gustado o tienes alguna duda, puedes dejar aquí tu comentario.

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies