28 noviembre, 2021

TRANSPONER RANGO EN HORIZONTAL SEGÚN NÚMERO DE ELEMENTOS REPETIDOS CON FÓRMULAS

Hola a todos!.

Como punto final a la serie de post dedicados a transponer un rango en horizontal según número de elementos repetidos, he decidido incluir una solución con fórmulas.

Y seguiremos utilizando el archivo de ejemplo del principio:

El proceso utiliza dos pasos para generar la información, en el primero aplicaremos la fórmula UNICOS para extraer los elementos únicos de la columna A:

Una vez que tenemos los únicos aplicaremos en E2 la siguiente fórmula:

=SI.ERROR(INDICE($B$2:$B$6500;AGREGAR(15;6;(FILA($A$2:$A$6500)-FILA($A$2)+1)/($A$2:$A$6500=$D2);COLUMNAS($B2:B2)));"")

Y a continuación arrastramos hasta la columna que creamos que es suficiente para contener todos los elementos (en este caso número de hijos).

Obteniendo así el resultado previsto:

Ojo que se trata de una fórmula matricial y debe ser ejecutada como tal Control + Mayusc + Enter, pero al estar trabajando con office 365 no es necesario.

Básicamente lo que hacemos es obtener el número de fila en el que se encuentra cada elemento con la función agregar y una vez obtenida la coincidencia indicamos con la función INDICE el elemento que debemos mostrar. Y finalmente ocultamos los valores que no aplican.

Así es cómo se ve la tabla aplicando solo esa parte de la función (no he aplicado si.error para que se vea cómo que tras aplicar las primeras funciones):

Aunque sin duda, los métodos con Power Query y Python son los más rápidos (aunque aún no he probado con typescript ni con ADO), esta alternativa puede que también sea útil, y por eso la publico.

Y esto es todo, espero que os resulte interesante!!

¿Te ha resultado de interés?, puedes apoyar a Excel Signum con una pequeña donación.

Donate Button with Credit Cards

¡¡Muchas gracias!!

Mediante la suscripción al blog, la realización comentarios o el uso del formulario de contacto estás dando tu consentimiento expreso al tratamiento de los datos personales proporcionados según lo dispuesto en la ley vigente (LOPD). Tienes más información al respecto en esta página del blog: Política de Privacidad y Cookies

Comparte este post

Si te ha gustado o tienes alguna duda, puedes dejar aquí tu comentario.

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies