18 septiembre, 2021

OBTENER LISTA DE FINES DE SEMANA ENTRE DOS FECHAS CON FÓRMULAS DE MATRIZ DINÁMICA

Hola a todos!.

Aunque estoy últimamente muy centrado con Python y typescript, no me gustaría dejar de lado Excel, de hecho una de mis últimas publicaciones ha sido una rutina en VBA.

Por eso, hoy que querido publicar algo sobre fórmulas y, en concreto, funciones de matriz dinámica que sean capaces de derramar los fines de semana que existen entre dos fechas.

Para hacer esto, vamos a utilizar la siguiente combinación de fórmulas:

=UNICOS(SI(DIASEM(SECUENCIA(SIFECHA(B1;B2;"D")+1;1;B1;1);11)>5;SECUENCIA(SIFECHA(B1;B2;"D")+1;1;B1;1);"");0;1)

Con la función secuencia generamos la lista de días entre la fecha inicio y la fecha fin:

=SECUENCIA(SIFECHA(B1;B2;"D")+1;1;B1;1)

Para identificar el número de día de la semana debemos introducir la función Diasem()

=DIASEM(SECUENCIA(SIFECHA(B1;B2;"D")+1;1;B1;1);11)

Una vez que tenemos el número de día de la semana, basta con especificar en un condicional que se genere únicamente aquellos números superiores a 5, es decir, el 6 =sábado y el 7= Domingo

=SI(DIASEM(SECUENCIA(SIFECHA(B1;B2;"D")+1;1;B1;1);11)>5;SECUENCIA(SIFECHA(B1;B2;"D")+1;1;B1;1);"")

Y finalmente aplicamos la función Unicos con el último argumento en true para omitir el espacio en blanco que nos queda del resultado de aplicar la fórmula anterior.

Otra alternativa sería utilizando DIA.LAB.INTL y combinándolo con DIAS.LAB.INTL:

=DIA.LAB.INTL(B1;SECUENCIA(DIAS.LAB.INTL(B1;B2;"1111100"));"1111100")

Y como podéis observar, el resultado es el esperado. Una relación de todos los fines de semana entre dos fechas.

Y esto es todo, espero que os sea de utilidad 🙂

¿Te ha resultado de interés?, puedes apoyar a Excel Signum con una pequeña donación.

Donate Button with Credit Cards

¡¡Muchas gracias!!

Mediante la suscripción al blog, la realización comentarios o el uso del formulario de contacto estás dando tu consentimiento expreso al tratamiento de los datos personales proporcionados según lo dispuesto en la ley vigente (LOPD). Tienes más información al respecto en esta página del blog: Política de Privacidad y Cookies

Comparte este post

Si te ha gustado o tienes alguna duda, puedes dejar aquí tu comentario.

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies