16 enero, 2022

SUMAR LOS ELEMENTOS NUMÉRICOS EN UNA CADENA ALFANUMÉRICA

Hola a todos!

Ya estamos en 2022 y como no podía ser de otra manera, hoy voy a publicar un post 🙂

Y lo haré sobre formulación!, que de vez en cuando está bien volver a los principios e ir entrenando el conocimiento de las fórmulas.

La tarea de hoy es simple en su planteamiento pero un poco compleja en su solución. Yo os daré la mía aunque existen otras formas mediante formulación.

Veamos, se trata de obtener la suma de los números que componen esta cadena alfanumérica:

eNQNYsjcnonOXlj2R7BLx3Hryae1XDt2qlUpNDP

Como podéis sumar, el sumatorio sería de: =2+7+3+1+2, es decir 15

Este resultado lo podréis obtener aplicando la siguiente fórmula, donde en A2 tenemos la cadena alfanumérica que hemos visto:

=SUMA(SI.ERROR(EXTRAE(A2;FILA(INDIRECTO("1:"&LARGO(A2)));1)*1;0))

En primer lugar, extraemos cada elemento a una celda aplicando esta parte de la fórmula:

=EXTRAE(A2;FILA(INDIRECTO("1:"&LARGO(A2)));1)

Una vez que tenemos esta información debemos validar si se trata de números o de texto, y eso lo haremos multiplicando por 1 de forma que si es texto devolverá un error:

=EXTRAE(A2;FILA(INDIRECTO("1:"&LARGO(A2)));1)*1

Y ahora utilizando la función Si.Error(), convertiremos los errores en un cero: 0

=SI.ERROR(EXTRAE(A2;FILA(INDIRECTO("1:"&LARGO(A2)));1)*1;0)

Y ahora que ya tenemos todo el rango numérico, podemos aplicar la suma obteniendo el total:

y es así como tenemos el resultado de la suma. Espero que os haya gustado el desarrollo y lo podáis aplicar a vuestros proyectos. La fórmula es de naturaleza matricial y si no estáis usando office 365 debéis aplicarla como tal.

Saludos!!

¿Te ha resultado de interés?, puedes apoyar a Excel Signum con una pequeña donación.

Donate Button with Credit Cards

¡¡Muchas gracias!!

Mediante la suscripción al blog, la realización comentarios o el uso del formulario de contacto estás dando tu consentimiento expreso al tratamiento de los datos personales proporcionados según lo dispuesto en la ley vigente (LOPD). Tienes más información al respecto en esta página del blog: Política de Privacidad y Cookies

Comparte este post

Si te ha gustado o tienes alguna duda, puedes dejar aquí tu comentario.

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies