29 mayo, 2022

SUMAR VARIAS COLUMNAS SEGÚN NOMBRE

Hola a todos:

Hoy vamos a escribir sobre excel y sobre fórmulas matriciales : )

La idea es dar una posible solución o alternativa a la siguiente necesidad: sumar el contenido de varias columnas según el título o nombre. Necesitaremos la suma completa de las columnas o la suma por cada línea.

En el ejemplo lo veréis muy claro:

De lo que se trata es de obtener las cifras de la columna I y de la columna L.

En el primer caso queremos sumar por cada ID el total de gastos, es decir, las columnas B + D + F y en el segundo el rango completo de las 3 columnas.

Utilizaremos la siguiente fórmula:

En la columna I:

=SUMAPRODUCTO((SI.ERROR(HALLAR("GAST";$A$1:$G$1;1);"0")*A2:G2))

En la columna L:

=SUMAPRODUCTO((SI.ERROR(HALLAR("GAST";A1:G1;1);"0")*A2:G32))

Se trata de utilizar la función Sumaproducto() para obtener los datos y aprovechar la función Hallar utilizándola para introducir «comodines». En este caso todo aquel nombre de columna que contenga las letras «GAST».

Ni que decir tiene que podríamos usar las funciones DERECHA, IZQUIERDA y ENCONTRAR (si queremos discriminar entre mayúsculas y minúsculas).

Cuando hacemos informes basados en fórmulas este tipo de alternativas es muy interesante.

¿Te ha resultado de interés?, puedes apoyar a Excel Signum con una pequeña donación.

Donate Button with Credit Cards

¡¡Muchas gracias!!

Mediante la suscripción al blog, la realización comentarios o el uso del formulario de contacto estás dando tu consentimiento expreso al tratamiento de los datos personales proporcionados según lo dispuesto en la ley vigente (LOPD). Tienes más información al respecto en esta página del blog: Política de Privacidad y Cookies

Comparte este post

Si te ha gustado o tienes alguna duda, puedes dejar aquí tu comentario.

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies