Hay ocasiones en las que tenemos que realizar operaciones en la que el resultado depende de la suma de X valores según sean los valores máximos o mínimos en esa matriz de datos.

Supongamos que debemos obtener el valor de la suma de los 4 valores máximos de una serie de datos que se muestran en una columna o por el contrario los 4 valores mínimos de una serie de datos.

Para al cálculo de los valores máximos, utilizaremos la función k.esimo.mayor ()

=SUMA(K.ESIMO.MAYOR(A2:A11;1);K.ESIMO.MAYOR(A2:A11;2);K.ESIMO.MAYOR(A2:A11;3);K.ESIMO.MAYOR(A2:A11;4))

Para el cálculo de los valores mínimos, utilizaremos la función: k.esimo.menor ()

=SUMA(K.ESIMO.MENOR(A2:A11;1);K.ESIMO.MENOR(A2:A11;2);K.ESIMO.MENOR(A2:A11;3);K.ESIMO.MENOR(A2:A11;4))

Estas fórmulas nos permitirán realizar las operaciones requeridas de forma precisa. Tendremos al instante el valor de la suma de los 4 (o los valores que se determinen) mayores o menos de un rango. El número de valores lo determina la función: K.ESIMO.MENOR(el rango de los datos "A2:A11" ; el número máximo de valores 4).

En el ejemplo lo veréis mejor:

SUMA VALORES MAXIMOS_MINIMOS RANGO

Como podéis observar, el resultado es exacto en ambas operaciones, y también muy sencillo de utilizar y entender.

Se podría utilizar una fórmula matricial para reducir la longitud de la fórmula, dejo la fórmula por si puede resultar interesante (os recuerdo que para activar la fórmula matricial «{ }» debéis seleccionar la fórmula y luego pulsar por este orden Ctrol+Mayús+Enter.

{=SUMA(K.ESIMO.MAYOR(A2:A11;{1;2;3;4}))} o para el caso de menor: {=SUMA(K.ESIMO.MENOR(A2:A11;{1;2;3;4}))}

Os dejo el archivo de ejemplo, espero que os sea de utilidad 🙂

Descarga el archivo pulsando enSUMAR VALORES MAXIMOS O MINIMOS DE UN RANGO DE DATOS

Comparte este post