SUMAR LOS VALORES MÁXIMOS O MÍNIMOS DE UN RANGO DE DATOS

Hay ocasiones en las que tenemos que realizar operaciones en la que el resultado depende de la suma de X valores según sean los valores máximos o mínimos en esa matriz de datos.

Supongamos que debemos obtener el valor de la suma de los 4 valores máximos de una serie de datos que se muestran en una columna o por el contrario los 4 valores mínimos de una serie de datos.

Para al cálculo de los valores máximos, utilizaremos la función k.esimo.mayor ()

=SUMA(K.ESIMO.MAYOR(A2:A11;1);K.ESIMO.MAYOR(A2:A11;2);K.ESIMO.MAYOR(A2:A11;3);K.ESIMO.MAYOR(A2:A11;4))

Para el cálculo de los valores mínimos, utilizaremos la función: k.esimo.menor ()

=SUMA(K.ESIMO.MENOR(A2:A11;1);K.ESIMO.MENOR(A2:A11;2);K.ESIMO.MENOR(A2:A11;3);K.ESIMO.MENOR(A2:A11;4))

Estas fórmulas nos permitirán realizar las operaciones requeridas de forma precisa. Tendremos al instante el valor de la suma de los 4 (o los valores que se determinen) mayores o menos de un rango. El número de valores lo determina la función: K.ESIMO.MENOR(el rango de los datos “A2:A11″ ; el número máximo de valores “4“).

En el ejemplo lo veréis mejor:

SUMA VALORES MAXIMOS_MINIMOS RANGO

Como podéis observar, el resultado es exacto en ambas operaciones, y también muy sencillo de utilizar y entender.

Se podría utilizar una fórmula matricial para reducir la longitud de la fórmula, dejo la fórmula por si puede resultar interesante (os recuerdo que para activar la fórmula matricial “{ }” debéis seleccionar la fórmula y luego pulsar por este orden Ctrol+Mayús+Enter.

{=SUMA(K.ESIMO.MAYOR(A2:A11;{1;2;3;4}))} o para el caso de menor: {=SUMA(K.ESIMO.MENOR(A2:A11;{1;2;3;4}))}

Os dejo el archivo de ejemplo, espero que os sea de utilidad 🙂

Descarga el archivo pulsando enSUMAR VALORES MAXIMOS O MINIMOS DE UN RANGO DE DATOS

 

Anuncios

10 pensamientos en “SUMAR LOS VALORES MÁXIMOS O MÍNIMOS DE UN RANGO DE DATOS

  1. He tratado de aplicar la formula pero el resultado, es dcir, la suma, no es correcta. Le dejo el ejemplo:

    C D E
    26 614 585 525
    27 633 579 555

    =SUMA(K.ESIMO.MAYOR(C26:E27;{1;2;3}))

    Total que me sale es: 1832

    Mucgas gracias.

    Saludos.

    Me gusta

    • Buenas tardes Javier,

      Pues el resultado que te sale es el correcto, es decir quieres obtener la suma de los tres valores máximos del rango seleccionado, y la fórmula suma 633+614+585: 1832. Este es el resultado correcto. ¿Cuál era el resultado que estabas buscando?.

      Saludos!!

      Me gusta

      • Hola. Buenas tardes.

        Lo que busco es que me sume el valor máximo de cada columna, es decir, 633+585-555. ¿Cómo puedo hacer para que me sume de cada columna es valor máximo? Muchas gracias.

        Me gusta

  2. Vale, entonces tienes que modificar la fórmula, dado que lo que buscas es un único valor máximo en cada columna y que además te sume el resultado de los totales, es decir que sea 633+585+555 un total de 1773. Para eso, y utilizando las mismas referencias a las celdas que tienes, sería así: =SUMA(K.ESIMO.MAYOR(C26:C27;1);K.ESIMO.MAYOR(D26:D27;1);K.ESIMO.MAYOR(E26:E27;1)) de forma que el “1” en cada fórmula representa el número más elevado de cada columna.

    Prueba a ver si es el resultado que necesitas.

    Saludos.

    Me gusta

    • Hola Soraya,

      Si te refieres a en una columna con diferentes rangos y cada uno con su máximo y mínimo, solo tendrías que aplicar la fórmula para cada tramo y sumar los resultados.

      De todas formas envía a excelsignum@yahoo.es el archivo de ejemplo, y como te gustaría que quedase. Así veo que necesitas.

      Saludos!!!

      Me gusta

    • Hola Andrés, funciona de la misma forma, solo que el rango es una fila. Obtienes la misma cifra. Debes adecuar la fórmula a los datos en horizontal y listo. Saludos.

      Me gusta

¿Te ha gustado?. Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s