SUMAR LOS VALORES MÁXIMOS O MÍNIMOS DE UN RANGO DE DATOS

Hay ocasiones en las que tenemos que realizar operaciones en la que el resultado depende de la suma de X valores según sean los valores máximos o mínimos en esa matriz de datos.

Supongamos que debemos obtener el valor de la suma de los 4 valores máximos de una serie de datos que se muestran en una columna o por el contrario los 4 valores mínimos de una serie de datos.

Para al cálculo de los valores máximos, utilizaremos la función k.esimo.mayor ()

=SUMA(K.ESIMO.MAYOR(A2:A11;1);K.ESIMO.MAYOR(A2:A11;2);K.ESIMO.MAYOR(A2:A11;3);K.ESIMO.MAYOR(A2:A11;4))

Para el cálculo de los valores mínimos, utilizaremos la función: k.esimo.menor ()

=SUMA(K.ESIMO.MENOR(A2:A11;1);K.ESIMO.MENOR(A2:A11;2);K.ESIMO.MENOR(A2:A11;3);K.ESIMO.MENOR(A2:A11;4))

Estas fórmulas nos permitirán realizar las operaciones requeridas de forma precisa. Tendremos al instante el valor de la suma de los 4 (o los valores que se determinen) mayores o menos de un rango. El número de valores lo determina la función: K.ESIMO.MENOR(el rango de los datos “A2:A11″ ; el número máximo de valores “4“).

En el ejemplo lo veréis mejor:

SUMA VALORES MAXIMOS_MINIMOS RANGO

Como podéis observar, el resultado es exacto en ambas operaciones, y también muy sencillo de utilizar y entender.

Se podría utilizar una fórmula matricial para reducir la longitud de la fórmula, dejo la fórmula por si puede resultar interesante (os recuerdo que para activar la fórmula matricial “{ }” debéis seleccionar la fórmula y luego pulsar por este orden Ctrol+Mayús+Enter.

{=SUMA(K.ESIMO.MAYOR(A2:A11;{1;2;3;4}))} o para el caso de menor: {=SUMA(K.ESIMO.MENOR(A2:A11;{1;2;3;4}))}

Os dejo el archivo de ejemplo, espero que os sea de utilidad 🙂

Descarga el archivo pulsando enSUMAR VALORES MAXIMOS O MINIMOS DE UN RANGO DE DATOS

 

Anuncios

15 pensamientos en “SUMAR LOS VALORES MÁXIMOS O MÍNIMOS DE UN RANGO DE DATOS

  1. He tratado de aplicar la formula pero el resultado, es dcir, la suma, no es correcta. Le dejo el ejemplo:

    C D E
    26 614 585 525
    27 633 579 555

    =SUMA(K.ESIMO.MAYOR(C26:E27;{1;2;3}))

    Total que me sale es: 1832

    Mucgas gracias.

    Saludos.

    Me gusta

    • Buenas tardes Javier,

      Pues el resultado que te sale es el correcto, es decir quieres obtener la suma de los tres valores máximos del rango seleccionado, y la fórmula suma 633+614+585: 1832. Este es el resultado correcto. ¿Cuál era el resultado que estabas buscando?.

      Saludos!!

      Me gusta

      • Hola. Buenas tardes.

        Lo que busco es que me sume el valor máximo de cada columna, es decir, 633+585-555. ¿Cómo puedo hacer para que me sume de cada columna es valor máximo? Muchas gracias.

        Me gusta

  2. Vale, entonces tienes que modificar la fórmula, dado que lo que buscas es un único valor máximo en cada columna y que además te sume el resultado de los totales, es decir que sea 633+585+555 un total de 1773. Para eso, y utilizando las mismas referencias a las celdas que tienes, sería así: =SUMA(K.ESIMO.MAYOR(C26:C27;1);K.ESIMO.MAYOR(D26:D27;1);K.ESIMO.MAYOR(E26:E27;1)) de forma que el “1” en cada fórmula representa el número más elevado de cada columna.

    Prueba a ver si es el resultado que necesitas.

    Saludos.

    Me gusta

    • Hola Soraya,

      Si te refieres a en una columna con diferentes rangos y cada uno con su máximo y mínimo, solo tendrías que aplicar la fórmula para cada tramo y sumar los resultados.

      De todas formas envía a excelsignum@yahoo.es el archivo de ejemplo, y como te gustaría que quedase. Así veo que necesitas.

      Saludos!!!

      Me gusta

    • Hola Andrés, funciona de la misma forma, solo que el rango es una fila. Obtienes la misma cifra. Debes adecuar la fórmula a los datos en horizontal y listo. Saludos.

      Me gusta

  3. Buenas:
    Se puede hacer esto mismo pero que solo tenga en cuenta las celdas que cumplan una condición?
    Es decir como si fuera un @sumar.si.conjunto(……. pero que solo sumarà los 4 máximos
    Muchas gracias

    Me gusta

    • Hola Pep:

      Lo podrías realizar con una matricial:

      =K.ESIMO.MAYOR(INDICE((B2:B11=”X”)*A2:A11;0);1)

      En este caso, recoge el valor del numero más alto de la columna A y donde además en la columna B tenga una “X”. Si no tiene X no evalúa.

      Saludos. Recuerda, es matricial, debes introducirla con Ctrol+Mayús+Enter.

      Saludos.

      Me gusta

      • Buenas:
        Al final parece que he conseguido algo parecido a lo que quería gracias a tu ayuda.
        De todas maneras me falta identificar de alguna manera las celdas que ha usado para el sumatorio (suma de 6 celdas como máximo) de los números máximos, pues de estos importes tengo que hacer un certificado.
        Abusando de la confianza, adjunto un archivo para ver si consigo explicarme (lo envío a excelsignum@yahoo.es). Verás la fórmula que he usado que como comprobarás supongo que se puede optimizar.
        Muchas gracias y saludos

        Me gusta

        • Hola Pep:

          He visto el archivo, pero no explicas nada acerca de lo que deseas obtener, qué quieres obtener con las fórmulas desarrolladas. Necesitaría una explicación acerca de los datos. ¿Qué quieres expresar en las celdas en las que tienes un interrogante?.

          Gracias!

          Me gusta

          • Buenos días:
            En las celdas de la columna P se enseña el sumatorio más alto de hasta las seis obras correspondientes a un año de los cinco que intervienen. Lo que debería salir en la columna R sería el año que corresponde al sumatorio (en la columna Q lo he hecho de forma manual como “resultado previsto”).
            Lo que me hace falta también es identificar las celdas de entre las columnas B y N cuyos números han participado en el sumatorio de la columna P
            Te adjunto de nuevo el archivo que lo he simplificado
            Muchas gracias

            Me gusta

¿Te ha gustado?, Realiza un comentario.

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.