SUMAR UN RANGO EN FILAS (EN HORIZONTAL) DEPENDIENDO DE UN VALOR

Hola a todos 🙂

Espero que todo os vaya bien!.

El post de hoy va a ser muy corto y será ampliación de un post anterior fruto de la consulta de un lector. En concreto el post es el siguiente: SUMAR UN RANGO DEPENDIENDO DE UN VALOR

En esa publicación lo que se expone es la forma de sumar un rango de números en función de un valor, o lo que es lo mismo, sumar utilizando un rango dinámico.

Lo que el lector solicitaba era poder hacer el mismo ejercicio pero estando el rango de la suma en una fila y no una columna, es decir, en horizontal. Pues bien, para solucionar esta duda, utilizaremos el siguiente ejemplo, donde debajo de cada mes se encuentra una cifra (que pueden ser datos de negocio, de facturación , etc):

SUMAR UN RANGO EN FILAS (EN HORIZONTAL) DEPENDIENDO DE UN VALOR

Y debemos introducir la siguiente fórmula para realizar la operación:

=SUMA(A2:INDIRECTO("F2C"&B4;0))

Para determinar la referencia al rango que se encuentra en la función INDIRECTO, debemos hacer uso del estilo de referencia F1C1 que nos permite indicar fila y columna. De modo que podemos vincular un valor a la columna y establecer la fila en el 2 (segunda fila). La fórmula traducida en el ejemplo es: =Suma(A2:K2)

Como podéis observar, la suma hasta el mes de Noviembre es de 894

Pero también podemos sumar un rango de varias filas, por ejemplo así:

SUMAR UN RANGO EN FILAS (EN HORIZONTAL) DEPENDIENDO DE UN VALOR2.jpg

Solo tenemos que indicar el rango a sumar en la fórmula indicando la fila 6 y la columna 11:

=SUMA(A2:INDIRECTO("F6C"&B8;0))

Y el resultado es de 7.214 🙂

Ya sé que es un post muy cortito, pero el hecho que me lo hayan planteado en una consulta, quiere decir que tiene utilidad.

Descarga el archivo de ejemplo pulsando en: SUMAR UN RANGO EN FILAS (EN HORIZONTAL) DEPENDIENDO DE UN VALOR

 

Anuncios