23 abril, 2021

FUNCIÓN CONTAR.SI.CONJUNTO Y FUNCIÓN SUMAPRODUCTO EN EXCEL

En la entrada de hoy voy a comentar la utilidad de la función CONTAR.SI.CONJUTO que está a nuestra disposición desde la versión 2007 de Excel y de la posibilidad de realizar el mismo trabajo en 2003 utilizando la función SUMAPRODUCTO.

Como siempre vamos a utilizar un ejemplo práctico para ilustrar mejor el funcionamiento de las fórmulas. Imaginad que tenemos un tabla de datos con las siguientes columnas:

- Género: "Masculino"; "Femenino"
- Código Postal: "Cualquier código postal de España"
- Fecha de nacimiento: "La más antigua desde el año 1946"

Y se nos requiere informar de cuantas personas de género "masculino", que viven en el código de provincia "15" y que hallan nacido entre el año "01/01/1958 o posterior".

Para realizar la tarea vamos a utilizar la función "CONTAR.SI.CONJUNTO" pero debéis tener en cuenta que en versiones anteriores a Excel 2007 no funcionará, luego propondré una alternativa para todas las versiones.

La fórmula aplicada quedaría así y fijaos en la sintaxis:

=CONTAR.SI.CONJUNTO($A$2:$A$65000;"=MASCULINO";$B$2:$B$65000;"=15";$C$2:$C$65000;">=01/01/1958")

Como se puede apreciar, marcamos en cada matriz de datos el criterio que queremos que condicione nuestro recuento, (siempre entre comillas cuando escribimos el criterio, en caso de hacer referencia a una celda, no serían necesarias). El resultado son 13 casos:

FUNCION CONTAR.SI.CONJUNTO Y FUNCION SUMAPRODUCTO EN EXCEL_1

Como podéis ver, esta fórmula filtra y cuenta los casos según nuestros criterios, es muy útil para cuanto tenemos que reportar periódicamente datos, dado que solo tendremos que actualizar nuestra base de datos y la función realizará el resto.

Pero claro, tenemos el problema de las versiones de Excel, y dado que la versión 2003 sigue muy presente en nuestras vidas (después de 11 años) tendremos que buscar una alternativa, y la mejor opción según mi criterio (hay otras), sería utilizar la función SUMAPRODUCTO.

Como vamos a ver llegaremos al mismo resultado, si bien al ser una fórmula diferente la sintaxis varía y también la manera de introducir los datos. La fórmula quedaría así:

=SUMAPRODUCTO(($A$2:$A$65000="Masculino")*1;($B$2:$B$65000=15)*1;($C$2:$C$65000>=21186)*1)

La función SUMAPRODUCTO sirve, como su nombre indica, para la suma de productos, de números según criterios, pero en este caso no vamos a sumar cantidades, sino valores. Para ello debemos multiplicar por 1 al final de cada matriz de datos, ejem: =SUMAPRODUCTO(($A$2:$A$65000="Masculino")*1

Otra peculiaridad es que las comillas se usan solo cuando hablamos de valores, con número no son necesarias, ejem: =SUMAPRODUCTO(($A$2:$A$65000="Masculino")*1;($B$2:$B$65000=15)*1

Por último, en el caso de las fechas, debemos hacer un pequeño truco, dado que la función no reconocerá el formato de fecha 00/00/0000 y para ello debemos escribir en un celda la fecha con la queremos condicionar el resultado: 01/01/1958 y a continuación con el ratón nos ponemos encima pulsamos botón derecho y cambiamos el formato de la celda a formato de texto, de forma que obtendremos un valor: 21186. Este valor es que utilizaremos ahora en lugar de 01/01/1958.

Ahora sí que nos funcionará la fórmula y el resultado es el mismo, 13 casos.

FUNCION CONTAR.SI.CONJUNTO Y FUNCION SUMAPRODUCTO EN EXCEL_2

Otro truco, es que si queremos prescindir de trabajar con formato de fecha, sería mostrando solo el año y utilizando la función Año() que extraerá de la celda el año de la fecha. Como podéis ver, el resultado es el mismo: 13 casos

FUNCION CONTAR.SI.CONJUNTO Y FUNCION SUMAPRODUCTO EN EXCEL_3

Y este ha sido el post de hoy, espero que podáis contar todos aquellos casos sin temor a los criterios que tengáis que tener en cuenta 🙂

Descarga el archivo pulsando enFUNCIÓN CONTAR.SI.CONJUNTO Y FUNCIÓN SUMAPRODUCTO EN EXCEL

 

Comparte este post

2 comentario en “FUNCIÓN CONTAR.SI.CONJUNTO Y FUNCIÓN SUMAPRODUCTO EN EXCEL

Si te ha gustado o tienes alguna duda, puedes dejar aquí tu comentario.

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies