OBTENER SUMA DE UN RANGO QUE CONTIENE ERRORES

Hola a todos!:

Últimamente recibo muchos correos preguntando por pequeños problemas cotidianos cuando usamos Excel, uno muy recurrente es el de obtener una suma de un rango que contiene errores.

Por ejemplo:

obtener suma de un rango que contiene errores

Como podéis observar, en el rango tenemos un error y por lo tanto el resultado de la función suma devuelve nos devuelve error.

Para poder solucionar este problema podemos recurrir a la función SI.ERROR y combinarla con SUMA y ejecutarla matricialmente. Esta sería la fórmula:

{=SUMA(SI.ERROR(B2:B20;""))}

Este es el resultado:

obtener suma de un rango que contiene errores1

Os recuerdo que las matrices se introducen: seleccionando la fórmula y luego presionando CTRL + MAYUS + ENTRAR.

Y eso es todo, un truco sencillo que nos puede ayudar en nuestros reportes, sobre todo cuando los datos que nos llegan contiene errores.

Descarga el archivo de ejemplo pulsando en: OBTENER SUMA DE UN RANGO QUE CONTIENE ERRORES

¿Te ha resultado de interés?, puedes apoyar a Excel Signum con una pequeña donación.

Donate Button with Credit Cards

¡¡Muchas gracias!!

Mediante la suscripción al blog, la realización comentarios o el uso del formulario de contacto estás dando tu consentimiento expreso al tratamiento de los datos personales proporcionados según lo dispuesto en la ley vigente (LOPD). Tienes más información al respecto en esta página del blog: Política de Privacidad y Cookies

Anuncios

SUMAR CADA N VALOR DE UN RANGO

No es la primera vez que tengo que recurrir a código cuando necesito realizar alguna tarea a la que las fórmulas no son capaces de llegar. Pero esto no siempre sucede, en algunas ocasiones, fruto de la combinación de funciones podemos llegar a resultados igual de satisfactorios.

Por ejemplo, podemos sumar cada n valor de un rango de celdas, es decir, por ejemplo, sumar el contenido de cada dos celdas.

SUMAR CADA N VALOR DE UN RANGO

En este ejemplo he marcado en azul las celdas que necesito sumar, que son las que van de dos en dos (sin tener en cuenta el encabezado). El resultado debe darnos 156.

Para lograr el cálculo debemos utilizar la siguiente fórmula o función:

{=SUMA(SI(RESIDUO(FILA(INDIRECTO("1:"&CONTARA(A1:A26)))-1;2)=0;A1:A26;""))}

En realidad la clave de esta función matricial se apoya en el uso de la función residuo, condicionando su resultado a que los números del rango (matriz) se consideren o no para la suma. Esto lo podéis observar si aplicáis solo parte de la fórmula pero en otra columna, en la “B”:

{=SI(RESIDUO(FILA(INDIRECTO("1:"&CONTARA($A$1:$A$26)))-1;2)=0;$A$1:$A$26;"")}

Este sería el resultado:

SUMAR CADA N VALOR DE UN RANGO1

Como podéis ver, cuando el resultado de Residuo es cero, es lo mismo que decir que la fila es divisible por ese “n” número definido, en este caso el 2. Al ser cierto, la función “si” condicional, toma ese número en la suma y si no lo es, no lo incluye. En el ejemplo de arriba, simplemente he aplicado parte de fórmula para lo que veáis.

De nuevo os recuerdo que las matrices se introducen: seleccionando la fórmula y luego presionando CTRL + MAYUS + ENTRAR

Aunque no tenía intención, al final no me pude resistir y he reproducido el mismo ejercicio pero con macros. Se puede hacer de muchas formas, pero lo he resuelto con un bucle for next:

Sub SUMAR_N_VALORES()
With Sheets(1)
Dim i As Double
Dim j As Double
fin = Application.CountA(.Range("A:A"))
'Desde la celda 2 hasta fin menos 1 (cabecero) e incrementando de 2 en 2
For i = 2 To fin - 1 Step 2
'Acumulamos en j el resultado de la suma
j = j + i
Next i
'Igualamos valor de celda a resultado
.Cells(2, 3) = j
End With
End Sub

El resultado es exactamente el mismo utilizando tanto la fórmula como la macro:

SUMAR CADA N VALOR DE UN RANGO

Ahora solo queda que lo adaptéis a vuestros proyectos y trabajos y obtengáis los beneficios de trabajar con Excel.

Descarga el archivo de ejemplo pulsando en: SUMAR CADA N VALOR DE UN RANGO