SUMAR UN RANGO EN FILAS (EN HORIZONTAL) DEPENDIENDO DE UN VALOR

Hola a todos 馃檪

Espero que todo os vaya bien!.

El post de hoy va a ser muy corto y ser谩 ampliaci贸n de un post anterior fruto de la consulta de un lector. En concreto el post es el siguiente:聽SUMAR UN RANGO DEPENDIENDO DE UN VALOR

En esa publicaci贸n lo que se expone es la forma de sumar un rango de n煤meros en funci贸n de un valor, o lo que es lo mismo, sumar utilizando un rango din谩mico.

Lo que el lector solicitaba era poder hacer el mismo ejercicio pero estando el rango de la suma en una fila y no una columna, es decir, en horizontal. Pues bien, para solucionar esta duda, utilizaremos el siguiente ejemplo, donde debajo de cada mes se encuentra una cifra (que pueden ser datos de negocio, de facturaci贸n , etc):

SUMAR UN RANGO EN FILAS (EN HORIZONTAL) DEPENDIENDO DE UN VALOR

Y debemos introducir la siguiente f贸rmula para realizar la operaci贸n:

=SUMA(A2:INDIRECTO("F2C"&B4;0))

Para determinar la referencia al rango que se encuentra en la funci贸n INDIRECTO, debemos hacer uso del estilo de referencia F1C1 que nos permite indicar fila y columna. De modo que podemos vincular un valor a la columna y establecer la fila en el 2 (segunda fila). La f贸rmula traducida en el ejemplo es: =Suma(A2:K2)

Como pod茅is observar, la suma hasta el mes de Noviembre es de 894

Pero tambi茅n podemos sumar un rango de varias filas, por ejemplo as铆:

SUMAR UN RANGO EN FILAS (EN HORIZONTAL) DEPENDIENDO DE UN VALOR2.jpg

Solo tenemos que indicar el rango a sumar en la f贸rmula indicando la fila 6 y la columna 11:

=SUMA(A2:INDIRECTO("F6C"&B8;0))

Y el resultado es de 7.214 馃檪

Ya s茅 que es un post muy cortito, pero el hecho que me lo hayan planteado en una consulta, quiere decir que tiene utilidad.

Descarga el archivo de ejemplo pulsando en:聽SUMAR UN RANGO EN FILAS (EN HORIZONTAL) DEPENDIENDO DE UN VALOR

 

Anuncios