USO COMBINADO DE LA FUNCIÓN INDICE Y COINCIDIR

Hola a todos!

Hoy toca formulación!, No todo van a ser macros y programación : )

Hace unos días me enviaron una consulta en la que solicitaban una fórmula para mostrar cierta información.

Os mostraré un ejemplo de sencillo de lo que se buscaba y las fórmulas que utilicé. Primero veamos los datos y que se necesita buscar:

USO COMBINADO DE LA FUNCIÓN INDICE Y COINCIDIR

Como podéis observar, necesitamos mostrar en la columna “B” la fecha que aparece en fila 3, pero en función de la coincidencia del importe que aparece en la columna A. Es decir, en la celda B6 debe aparecer la fecha: “2015”, en la B7: “2016” y así en adelante.

Para hacer esto (se puede hacer de varias formas), os propongo utilizar las funciones COINCIDIR e INDICE.

Con la primera podemos extraer el número de columna en la que se encuentra el dato buscado:

=COINCIDIR(A6;C6:J6;0)

El resultado sería “5”

Con la segunda, vamos a ser capaces de localizar la fecha, debemos analizar su sintaxis para comprenderlo mejor:

Indice (matriz, número de fila, número de columna).

Matriz: sería C3:J3
Fila: la 1
Columna: COINCIDIR(A6;C6:J6;0)

Ambas funciones combinadas darían lugar a esta fórmula:

=INDICE($C$3:$J$3;1;COINCIDIR(A6;C6:J6;0))

Y el resultado es el esperado:

USO COMBINADO DE LA FUNCIÓN INDICE Y COINCIDIR1

Como podéis observar es una función bastante sencilla pero muy eficiente utilizando ambas fórmulas.

Os dejo el archivo para lo probéis : )

Descarga el archivo de ejemplo pulsando en: USO COMBINADO DE LA FUNCIÓN INDICE Y COINCIDIR

¿Te ha resultado de interés?, puedes apoyar a Excel Signum con una pequeña donación.

Donate Button with Credit Cards

¡¡Muchas gracias!!

Mediante la suscripción al blog, la realización comentarios o el uso del formulario de contacto estás dando tu consentimiento expreso al tratamiento de los datos personales proporcionados según lo dispuesto en la ley vigente (LOPD). Tienes más información al respecto en esta página del blog: Política de Privacidad y Cookies

Anuncios