SUMAS ACUMULADAS POR RANGO SEGÚN CRITERIOS

Hola a todos:

Hoy vamos a seguir con las fórmulas, en concreto con el mundo de las sumas acumuladas y la problemática que surge en determinados casos.

Pongamos un ejemplo visual del problema:

SUMAS ACUMULADAS POR RANGO SEGÚN CRITERIOS

Como podéis observar se trata de obtener el sumatorio de los importes en cada rango en función de si en la columna C hay datos (en este caso, fechas).

Esta tarea es posible que se pueda resolver con una fórmula matricial (tengo pendiente estudiarlo), sin embargo, lo podemos resolver con una combinación de varias fórmulas:

En concreto la fórmula que os propongo es la siguiente:

=SI(FILA(B2)>2;SI.ERROR(SI(C2<>"";SUMA($A$2:INDIRECTO("A"&FILA(B2)));"")-SUMA($B$2:INDIRECTO("B"&(FILA(C2)-1)));"");SI(C2<>"";SUMA($A$2:INDIRECTO("A"&FILA(B2)));""))

Es importante en esta fórmula tener presente el número de fila en el que estamos situados en cada momento, dado que la segunda celda (teniendo en cuenta que tenemos encabezados), la fórmula será diferente a las demás, por ello indico un condicional al inicio de la fórmula dependiendo de si la fila en la que estamos es mayor o menor de 2.

La idea es primero capturar el acumulado desde la fila A2 hasta la fila en la que estamos:

=SUMA($A$2:INDIRECTO("A"&FILA(B2)))

Y luego restar lo que ya hemos acumulado

-SUMA($B$2:INDIRECTO("B"&(FILA(C2)-1)))

De esta forma conseguimos el resultado requerido.

SUMAS ACUMULADAS POR RANGO SEGÚN CRITERIOS_1

Y eso es todo : )

Espero que os sea de utilidad!.

Descarga el archivo de ejemplo pulsando en: SUMAS ACUMULADAS POR RANGO SEGÚN CRITERIOS

¿Te ha resultado de interés?, puedes apoyar a Excel Signum con una pequeña donación.

Donate Button with Credit Cards

¡¡Muchas gracias!!

Mediante la suscripción al blog, la realización comentarios o el uso del formulario de contacto estás dando tu consentimiento expreso al tratamiento de los datos personales proporcionados según lo dispuesto en la ley vigente (LOPD). Tienes más información al respecto en esta página del blog: Política de Privacidad y Cookies

Anuncios

¿Te ha gustado?, Realiza un comentario.

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.