OBTENER SUMA DE UN RANGO QUE CONTIENE ERRORES

Hola a todos!:

Últimamente recibo muchos correos preguntando por pequeños problemas cotidianos cuando usamos Excel, uno muy recurrente es el de obtener una suma de un rango que contiene errores.

Por ejemplo:

obtener suma de un rango que contiene errores

Como podéis observar, en el rango tenemos un error y por lo tanto el resultado de la función suma devuelve nos devuelve error.

Para poder solucionar este problema podemos recurrir a la función SI.ERROR y combinarla con SUMA y ejecutarla matricialmente. Esta sería la fórmula:

{=SUMA(SI.ERROR(B2:B20;""))}

Este es el resultado:

obtener suma de un rango que contiene errores1

Os recuerdo que las matrices se introducen: seleccionando la fórmula y luego presionando CTRL + MAYUS + ENTRAR.

Y eso es todo, un truco sencillo que nos puede ayudar en nuestros reportes, sobre todo cuando los datos que nos llegan contiene errores.

Descarga el archivo de ejemplo pulsando en: OBTENER SUMA DE UN RANGO QUE CONTIENE ERRORES

¿Te ha resultado de interés?, puedes apoyar a Excel Signum con una pequeña donación.

Donate Button with Credit Cards

¡¡Muchas gracias!!

Mediante la suscripción al blog, la realización comentarios o el uso del formulario de contacto estás dando tu consentimiento expreso al tratamiento de los datos personales proporcionados según lo dispuesto en la ley vigente (LOPD). Tienes más información al respecto en esta página del blog: Política de Privacidad y Cookies

Anuncios

2 pensamientos en “OBTENER SUMA DE UN RANGO QUE CONTIENE ERRORES

  1. Perfecto muchas gracias por el aporte. Podrias explicar ese metodo matricial? en que cobsiste y cuando se aplica o porque… alguna vez lo he usado con la función Kesimo, pero no se muy bien el motivo.
    muchas gracias por tu trabajo.

    Me gusta

Responder a Lucas Cancelar respuesta

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.