USO COMBINADO DE LAS FUNCIONES SUMAPRODUCTO E IGUAL, DISCRIMINAR MAYÚSCULAS Y MINÚSCULAS.

Hola  a todos:

Hoy seguiré hablando sobre fórmulas, aunque muchas de las consultas que me envían son sobre programación, lo cierto es que también me llegan muchas dudas sobre fórmulas y cómo utilizarlas, por lo que creo que es interesante darle visibilidad para que todos nos podamos beneficiar : )

Esta es la consulta que me enviaban:

“Hola, tengo una consulta. El countif no diferencia entre mayusculas y minusculas. Si tengo el nombre “CASA” y en otra celda “casa” dirá que es duplicado pero yo necesito que lo diferencie. Alguna idea?

muchas gracias”

 

Pues bien, el tema de la discriminación de mayúsculas y minúsculas cuando usamos fórmulas suele ser bastante recurrente y en el caso que nos ocupa, el lector necesita contar y por lo tanto diferenciar las minúsculas y mayúsculas.

Para solucionar esto, tenemos varias posibilidades y aunque algunas de ellas requieren utilizar columnas auxiliares (algo que suelo utilizar solo cuando no queda más remedio), lo más eficiente es trabajar con una única celda.

Vamos con un ejemplo:

USO COMBINADO DE LAS FUNCIONES SUMAPRODUCTO E IGUAL

En la columna C debemos contar las veces que se repite “cultura y ocio” en minúscula. Pues bién para hacerlo utilizaremos la combinación de la función SUMAPRODUCTO e IGUAL:

=SUMAPRODUCTO(IGUAL($C$2:$C$64980;"cultura y ocio")*1)

También se podría omitir la multiplicación del 1 del final (necesario para pasar los datos a número de la función sumaproducto, utilizando el siguiente operador “–“:

=SUMAPRODUCTO(--IGUAL($C$2:$C$64980;"cultura y ocio"))

En ambos casos el resultado es de “3”

Y si necesitamos introducir otra condición, también lo podemos hacer. Por ejemplo las veces que se repite “cultura y ocio” y el sexo es MUJER:

=SUMAPRODUCTO(IGUAL($C$2:$C$64980;"cultura y ocio")*1;(IGUAL($E$2:$E$64980;"MUJER")*1))

O también:

=SUMAPRODUCTO(--IGUAL($C$2:$C$64980; "cultura y ocio");--(IGUAL($E$2:$E$64980;"MUJER")))

El resultado es 1 en los dos casos.

USO COMBINADO DE LAS FUNCIONES SUMAPRODUCTO E IGUAL1

Os dejo el ejercicio con las fórmulas utilizadas. Por cierto, para mostrarlas, he utilizado la función =formulatexto() que sirve para mostrar las fórmulas que contiene una celda.

Descarga el archivo de ejemplo pulsando en: USO COMBINADO DE LAS FUNCIONES SUMAPRODUCTO E IGUAL

¿Te ha resultado de interés?, puedes apoyar a Excel Signum con una pequeña donación.

Donate Button with Credit Cards

¡¡Muchas gracias!!

Mediante la suscripción al blog, la realización comentarios o el uso del formulario de contacto estás dando tu consentimiento expreso al tratamiento de los datos personales proporcionados según lo dispuesto en la ley vigente (LOPD). Tienes más información al respecto en esta página del blog: Política de Privacidad y Cookies

Anuncios

¿Te ha gustado?, Realiza un comentario.

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.